Login page not loading
Incident Report for Procore Technologies
Resolved
The redirect issue on Procore's login page has been resolved. We apologize for the inconvenience and thank you for your patience.
Posted over 1 year ago. Jun 21, 2016 - 14:01 PDT
Investigating
We are aware of a redirect error on Procore's login page. We are investigating and will provide an update as soon as possible.
Posted over 1 year ago. Jun 21, 2016 - 13:48 PDT