Delayed Response From Our Support Team
Incident Report for Procore Technologies
Resolved
Response times from Procore Support have returned to normal. We'll provide another update if the situation changes. Thank you for your patience.
Posted 6 days ago. Dec 05, 2017 - 16:28 PST
Monitoring
You may experience slower response times from our Support team, as we are short handed due to evacuations stemming from the Thomas Fire currently impacting areas near Procore's headquarters in Carpinteria, CA. Our team at headquarters is safe, and the fire poses no risk to your data or the functionality of the application. We truly appreciate your patience during this time.
Posted 7 days ago. Dec 05, 2017 - 12:21 PST