Web Interface Outage
Incident Report for Procore Technologies
Resolved
Our web interface is back up and running. Once again, we apologize for the inconvenience and thank you for your patience.
Posted about 1 year ago. Nov 30, 2016 - 17:19 PST
Investigating
Procore's web interface is currently experiencing an outage. Our engineers are investigating, and will provide an update as soon as one becomes available. We apologize for the inconvenience.
Posted about 1 year ago. Nov 30, 2016 - 17:14 PST