Amazon S3 Outage
Incident Report for Procore Technologies
Resolved
We have now processed all enqueued emails and uploads, and all functionality has been restored. We are now considering all issues resolved. From all of us, thank you for your patience.
Posted 10 months ago. Feb 28, 2017 - 19:18 PST
Monitoring
We have restored Procore's features and services which we had intentionally disabled earlier in the day to allow us to maintain at least partial functionality during the Amazon S3 outage. Core functionality is now restored, and we will over the next few hours be processing the backlog of emails, uploads, etc. that were enqueued throughout the day. We will continue to monitor the situation. Thank you for your patience.
Posted 10 months ago. Feb 28, 2017 - 17:00 PST
Update
We've restored partial service to Procore's web application. Services which rely on Amazon S3 (e.g., Drawings, Documents, Specifications, etc.) will remain non-functional until the root cause is fixed. Amazon has reportedly identified the issue and is working on a solution. We will provide further updates as they become available.
Posted 10 months ago. Feb 28, 2017 - 11:51 PST
Update
It appears that inbound chats, emails, and phone calls to our support teams are experiencing issues related to the outage. We will continue to do everything possible to restore this service.
Posted 10 months ago. Feb 28, 2017 - 11:32 PST
Update
We are aware that users can no longer access Procore and are working to restore access to the web app. In the meantime, Amazon is continuing its effort to remediate the root cause of the problem. We will provide further updates as soon as they become available.
Posted 10 months ago. Feb 28, 2017 - 11:26 PST
Update
We've determined that the current issues are related to an Amazon S3 outage. We've released a patch to mitigate the effects on Procore, but users may continue to receive intermittent 500 errors until the issue is resolved. Procore services which rely heavily on Amazon S3 such as Drawings, Documents and Specifications will not be usable at this time. We will provide further updates as soon as they become available.
Posted 10 months ago. Feb 28, 2017 - 10:17 PST
Investigating
We're receving reports of degraded performance and intermittent 500 errors across the web app. We are investigating and will provide further updates as soon as they become available.
Posted 10 months ago. Feb 28, 2017 - 09:59 PST