Web Interface Outage
Incident Report for Procore Technologies
Resolved
Service has been restored. We sincerely thank you for your patience and apologize for any inconvenience caused.
Posted 10 months ago. Aug 11, 2017 - 14:50 PDT
Investigating
We're currently experiencing unplanned downtime of the web interface. Our engineers are working to address the issue and we will provide updates as soon as possible.
Posted 10 months ago. Aug 11, 2017 - 14:08 PDT