Intermittent Support Services Issues
Incident Report for Procore Technologies
Resolved
Our support services provider has now resolved the issues affecting inbound communications to our support team. We thank you for your patience, and apologize for any inconvenience this may have caused.
Posted 8 months ago. Mar 15, 2017 - 16:05 PDT
Identified
Our third-party support services provider is experiencing issues which are intermittently preventing our support team from receiving chats, phone calls, and emails. They are actively working toward a solution and we will provide further updates as soon as they become available. Thank you for your patience.
Posted 8 months ago. Mar 15, 2017 - 12:56 PDT