Some Outbound Email Blocked
Incident Report for Procore Technologies
Resolved
The IP addresses being blocked by the third party spam filter have been unlisted, and email delivery rates should now be back to normal. We will continue to monitor the service for any recurrence of the issue, but for now consider the issue to be resolved.
Posted May 17, 2018 - 17:00 PDT
Monitoring
Block rates are trending back to normal levels, and we're confident we'll be back to normal shortly. We'll continue to monitor until things are back to normal.
Posted May 17, 2018 - 13:00 PDT
Investigating
We're seeing an uptick in legitimate emails originating from Procore being blocked by an independent third-party spam filter. Our engineering team is working with our email provider to investigate. In the meantime, we recommend ensuring that your network follows the whitelisting guidelines referenced in this article: https://support.procore.com/faq/why-cant-i-receive-email-from-procore.
Posted May 17, 2018 - 09:19 PDT