Issues with Support Help Center
Incident Report for Procore Technologies
Resolved
All issues with our support help center have been resolved. We apologize for the inconvenience and thank you for your patience.
Posted about 1 year ago. Oct 13, 2016 - 12:15 PDT
Investigating
Our support help center is currently experiencing trouble and we are working on a solution. We are receiving chats, emails, and phone calls to our support center, but are unable to respond to them at this time. We apologize for the inconvenience and will update as soon as we have more information.
Posted about 1 year ago. Oct 13, 2016 - 12:02 PDT