Asset Caching Issue
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 26, 2017 - 16:06 PDT
Monitoring
We are aware of the issue currently affecting the Procore web interface. These have been resolved by clearing your web browser's cache. You can find browser-specific directions here if you need them: http://www.refreshyourcache.com/
If problems persist, you can contact our support team via Live Chat, Email, or Phone.
Posted 5 months ago. Jul 26, 2017 - 14:16 PDT