Issues With Support Help Center
Incident Report for Procore Technologies
Resolved
Our support services provider has now resolved the issues affecting inbound phone calls to our support team. We thank you for your patience, and apologize for any inconvenience this may have caused.
Posted 30 days ago. Sep 22, 2017 - 14:49 PDT
Identified
Our support help center is currently experiencing issues affecting our phone systems and we are unable to receive calls at this time. In the meantime, if you need to contact our support team we encourage you to reach us via email at support@procore.com or live chat. We thank you for your patience and will update as soon as we have more information.
Posted 30 days ago. Sep 22, 2017 - 14:12 PDT