Error Pages Across Application
Incident Report for Procore Technologies
Resolved
We have identified and resolved this issue. Tools across the application should now be fully operational.
Posted over 1 year ago. Jun 24, 2016 - 05:07 PDT
Investigating
We are currently investigating an issue where several tools across the application are receiving error pages. Current tools affects are drawings, specifications, budget, and potential change orders with schedule of values associated to them.
Posted over 1 year ago. Jun 24, 2016 - 05:03 PDT