Issues with Support Help Center
Incident Report for Procore Technologies
Resolved
All issues with our support help center have been resolved. We apologize for the inconvenience and thank you for your patience.
Posted about 1 year ago. Aug 26, 2016 - 11:20 PDT
Identified
Our support help center is currently experiencing issues affecting our chat and phone systems and we are working towards a solution. In the meantime, if you need to contact our support team we encourage you to reach us via email at support@procore.com. We thank you for your patience and will update as soon as we have more information.
Posted about 1 year ago. Aug 26, 2016 - 10:41 PDT
Investigating
Our support help center is currently experiencing trouble and we are working on a solution. This is affecting chats and phone calls. We apologize for the inconvenience and will update as soon as we have more information.
Posted about 1 year ago. Aug 26, 2016 - 09:25 PDT