Application Connectivity Issues
Incident Report for Procore Technologies
Resolved
All issues have now been resolved, thank you for your patience.
Posted over 1 year ago. May 31, 2016 - 04:07 PDT
Monitoring
All issues have now been resolved, thank you for your patience.
Posted over 1 year ago. May 31, 2016 - 03:10 PDT
Investigating
We are aware of an issue causing error pages for many users this morning across Procore and are working on a fix now.
Posted over 1 year ago. May 31, 2016 - 02:38 PDT