Delayed Response From Our Support Team
Incident Report for Procore Technologies
Resolved
Response times from our Support team have returned to normal. Thanks for your patience.
Posted 5 days ago. Dec 06, 2017 - 17:59 PST
Monitoring
As many of our employees are still impacted by evacuations stemming from the Thomas Fire near our headquarters in Carpinteria, CA, users may continue to experience slower-than-normal response times from our Support team. Once again, the fire poses no risk to your data or the functionality of the application. We truly appreciate your patience during this time.
Posted 6 days ago. Dec 06, 2017 - 08:54 PST