Degraded Performance
Incident Report for Procore Technologies
Resolved
All issues are now considered resolved. We apologize for the inconvenience and thank you for your patience.
Posted 6 months ago. May 03, 2017 - 18:47 PDT
Investigating
Procore is currently experiencing degraded performance. Some users may experience longer-than-average load times and in some cases intermittent service interruptions. Our engineers are aware and working diligently to resolve the issue. We apologize for the inconvenience, and thank you for your patience as we address the issue.
Posted 6 months ago. May 03, 2017 - 17:49 PDT