Multi-Person Pickers
Incident Report for Procore Technologies
Resolved
Multi-person contact pickers are functional once again. Thank you for your patience.
Posted over 1 year ago. Jul 21, 2016 - 14:12 PDT
Identified
Multi-Person contact pickers across various Procore tools are not retaining their values when saved. Our engineers are currently working on a fix. We apologize for the inconvenience, and thank you for your patience.
Posted over 1 year ago. Jul 21, 2016 - 13:13 PDT