Procore Outage
Incident Report for Procore Technologies
Resolved
Service has been restored and we now consider this issue resolved. Thanks for your patience.
Posted 13 days ago. Aug 03, 2017 - 16:15 PDT
Investigating
Investigating - Procore is currently experiencing a service outage. Our engineers are aware and working diligently to resolve the issue. Thank you for your patience.
Posted 13 days ago. Aug 03, 2017 - 16:09 PDT