Degraded Performance Loading Projects on Android
Incident Report for Procore Technologies
Resolved
This incident has been resolved. Any users affected by this issue will need to update to the latest version of the app to restore normal load times.
Posted Oct 25, 2020 - 09:16 PDT
Monitoring
An update for the Android app will be available shortly that will resolve this issue. We are monitoring this release to ensure a complete resolution.
Posted Oct 23, 2020 - 10:26 PDT
Investigating
Our R&D team is investigating an issue causing slow or failed loading of the Projects list in the Android App. Further updates will be provided as they are available.
Posted Oct 23, 2020 - 08:00 PDT
This incident affected: Mobile Platforms (Android Procore Application).