Intermittent Login and WBS loading Issues
Incident Report for Procore Technologies
Resolved
During the incident users were experiencing intermittent errors when logging into Procore and when loading their Work Breakdown Structure. Our engineering team has restored normal functionality and is confident there will be no recurrences. This incident has been resolved.

Impact Duration: [198] Minutes ([8:30AM] - [11:48] [PDT/PST])
Posted May 26, 2022 - 08:40 PDT
Monitoring
Our engineering team has implemented their solution for the issue causing a blank screen when logging into Procore and loading WBS. We are monitoring the situation to ensure a complete resolution.
Posted May 24, 2022 - 11:49 PDT
Investigating
Our engineering team is investigating an intermittent issue causing a blank screen when logging into Procore and when loading WBS for a subset of customers.

Additional Updates will be posted as they become available.
Posted May 24, 2022 - 09:35 PDT
This incident affected: Global Services (Login).