Slow Load Times and Error Pages
Incident Report for Procore Technologies
Resolved
Our Engineering Team has mitigated delays and load issues. This issue is now resolved.
Posted Dec 01, 2020 - 13:08 PST
Monitoring
We have restored normal load times and are monitoring the situation to ensure a full resolution.
Posted Dec 01, 2020 - 08:47 PST
Identified
We have identified the cause of the delays, and are working towards a resolution.
Posted Dec 01, 2020 - 08:41 PST
Investigating
We are investigating an issue causing delays and possible errors loading pages in Procore. Further updates will be posted as they become available.
Posted Dec 01, 2020 - 08:24 PST
This incident affected: Global Services (Web Interface).