Issue with the Pagination for the My Open Items lists in the Project and Company Home
Incident Report for Procore Technologies
Investigating
Our engineering team is investigating an issue where users may be experiencing an issue with the Pagination for the My Open Items lists in the Project and Company Home

Additional updates will be provided as new information becomes available.
Posted Jan 17, 2023 - 13:56 PST
This incident affects: Company Level Tools (Dashboards).