Issues with Creating Action Plans
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Action Plans tool and this issue is now resolved.
Posted Feb 22, 2021 - 11:31 PST
Investigating
Our Engineering Team is currently investigating issues with creating Action Plans. Updates will be posted as they become available.
Posted Feb 22, 2021 - 10:03 PST