Meeting Agenda View Issues
Incident Report for Procore Technologies
Resolved
The meetings page is now displaying properly again. This incident has been resolved.
Posted Nov 21, 2019 - 12:02 PST
Investigating
We are investigating issues with the Meeting Agenda view. Updates will be posted as they are available.
Posted Nov 21, 2019 - 10:36 PST
This incident affected: Project Level Tools (Meetings).