Downloading Files in Google Chrome
Incident Report for Procore Technologies
Resolved
The issue with downloading files in Google Chrome has been mitigated. This incident has been resolved.
Posted Nov 25, 2020 - 22:14 PST
Identified
Our Engineering team has identified the issue with downloading files via Google Chrome. While we work to restore normal functionality, customers can download files using alternative browsers such as Safari and Firefox.
Posted Nov 25, 2020 - 09:19 PST
Investigating
Our Engineering Team is currently investigating issues with downloading files in Google Chrome. Updates will be posted as they become available.
Posted Nov 25, 2020 - 07:28 PST
This incident affected: Global Services (File Downloads).