Some users experiencing upstream timeout errors when logging in and navigating Procore
Incident Report for Procore Technologies
Resolved
Engineering teams have validated complete resolution for this incident. All impacted functionality continues to be working as expected. This incident has been resolved.
Posted Nov 04, 2022 - 17:09 PDT
Monitoring
Download functionality is now fully restored. Procore downloads and login availability are functioning as expected at this time. Our Engineering team has implemented a solution to mitigate the intermittent download issues.

We understand this event was impactful, and we will continue to monitor the environments to ensure stability.

Additional updates will be provided as new information becomes available.
Posted Nov 04, 2022 - 14:23 PDT
Identified
Teams have restored functionality to login and mobile and are continuing to work on downloads. At this time users may be experiencing intermittent issues when downloading files.

We continue to work on this incident with the utmost priority, and appreciate your patience.
Additional updates will be provided as new information becomes available
Posted Nov 04, 2022 - 11:20 PDT
Update
Engineering teams have identified next steps for mitigating this incident. At this time users may still be experiencing the inability to log in to the Procore application via browser & Mobile instances. The site may be unavailable while we work to restore service. We are working on the issue with the utmost priority and appreciate your patience.

The next update will be provided within 30 minutes, or as new information becomes available.
Posted Nov 04, 2022 - 10:25 PDT
Update
Engineering teams continue to work to resolve the incident. At this time users may be experiencing the inability to log in to the Procore application via browser & Mobile instances. The site may be unavailable while we work to restore service. We are working on the issue with the utmost priority and appreciate your patience.

Additional updates will be provided within 30 minutes or as new information becomes available.
Posted Nov 04, 2022 - 09:52 PDT
Update
Engineering teams continue to work to resolve the incident. At this time users may be experiencing the inability to log in to the Procore application via browser & Mobile instances. The site may be unavailable while we work to restore service. We are working on the issue with the utmost priority and appreciate your patience.

Additional updates will be provided within 30 minutes or as new information becomes available.
Posted Nov 04, 2022 - 09:08 PDT
Update
Teams are continuing to investigate issues related to file uploads and downloads. The site may be unavailable for some users while we work to restore service. We are working on the issue with the utmost priority and appreciate your patience.

Additional updates will be provided within 30 minutes or as new information becomes available.
Posted Nov 04, 2022 - 08:49 PDT
Investigating
Engineering teams continue to investigate the issue that was previously producing upstream timeout errors when logging in or navigating the Procore Application. Teams have restored functionality to login and mobile and are continuing to work on downloads. At this time, users may be experiencing intermittent issues when attempting to download files.

We are working on this with the utmost priority and additional updates will be provided as new information becomes available.
Posted Nov 04, 2022 - 08:03 PDT
Monitoring
Our engineering team has implemented a solution for an issue where some users were experiencing upstream timeout errors when logging in and navigating Procore. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Nov 04, 2022 - 03:50 PDT
Investigating
Our engineering team is investigating an issue causing some users to experience upstream timeout errors when logging in and navigating Procore.

Additional Updates will be posted as they become available.
Posted Nov 04, 2022 - 03:40 PDT
This incident affected: Global Services (File Downloads, Web Interface).