Issues Accessing Procore Construction Network
Incident Report for Procore Technologies
Resolved
Our engineers have confirmed that the Procore Construction Network issues are no longer occurring, and this incident has been resolved.
Posted Aug 11, 2022 - 11:49 PDT
Monitoring
Our engineering team has implemented their solution and the Procore Construction Network is accessible once again. If you are continuing to experience this issue, please clear your browser's cache. We are monitoring the situation to ensure a complete resolution.
Posted Aug 11, 2022 - 10:59 PDT
Investigating
Our engineering team is investigating an issue preventing users from accessing the Procore Construction Network. We will post addition updates as they become available.
Posted Aug 11, 2022 - 07:36 PDT
This incident affected: Procore Construction Network (Web Interface).