Issues with Loading Dashboards
Incident Report for Procore Technologies
Resolved
We have restored normal functionality to our Dashboards. This incident has been resolved.
Posted Apr 09, 2021 - 16:13 PDT
Investigating
Our Engineering Team is currently investigating issues with accessing Dashboards. Updates will be posted as they become available.
Posted Apr 09, 2021 - 14:37 PDT
This incident affected: Company Level Tools (Dashboards).