Unable to Save Meeting Minutes
Incident Report for Procore Technologies
Resolved
The issue affecting meetings is now resolved. Thanks for your patience.
Posted 19 days ago. Jun 05, 2018 - 19:30 PDT
Investigating
Our engineering team is currently investigating an issue which is affecting follow up meeting creation, meeting creation from a template, and saving meeting minutes. We will provide another update as soon as one becomes available.
Posted 19 days ago. Jun 05, 2018 - 18:25 PDT
This incident affected: Project Meetings.