Punch uploads are stuck in the Android app
Incident Report for Procore Technologies
Resolved
During the incident, users experienced an issue causing punch items to be stuck in the upload queue in the Android application. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Sep 26, 2022 - 11:28 PDT
Monitoring
Our engineering team has implemented a solution for the issue causing punch items to be stuck in the upload queue in the Android application. Please update to the latest version (2022.0922.1230) to resolve the issue.
We will continue to monitor the situation to ensure a complete resolution.
Posted Sep 22, 2022 - 15:06 PDT
Identified
Our engineering team has identified an additional issue with punch items getting stuck in the upload queue in the Android application. We are actively working towards a solution.
Posted Sep 22, 2022 - 10:48 PDT
Monitoring
Our engineering team has implemented a solution for the issue causing punch items to be stuck in the upload queue in the Android application. Please update to the latest version (2022.0921.1052) to resolve the issue.

We will continue to monitor the situation to ensure a complete resolution.
Posted Sep 21, 2022 - 13:24 PDT
Identified
Our engineering team has identified the issue with punch items stuck in the upload queue in the Android application. We are actively working towards a solution.
Posted Sep 21, 2022 - 10:00 PDT
Investigating
Our engineering team is investigating an issue where users may experience an issue with punch items stuck in the upload queue in the Android application.
Posted Sep 21, 2022 - 09:44 PDT
This incident affected: Mobile Platforms (Android Procore Application) and Project Level Tools (Punch List).