RFI Overdue Emails
Incident Report for Procore Technologies
Resolved
This Incident has been resolved and RFI Overdue Emails are now sending as intended.
Posted 7 days ago. Dec 06, 2018 - 11:40 PST
Investigating
We are aware of reports of users getting multiple RFI overdue emails. Our Engineers are currently working to resolve the issue.
Posted 7 days ago. Dec 06, 2018 - 09:41 PST
This incident affected: Outbound Emails.