Issue viewing, uploading, and downloading files
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality and this issue is now resolved.
Posted Jun 24, 2020 - 20:56 PDT
Monitoring
We are no longer seeing issues when customers view, upload, or download files across Procore. We are continuing to monitor to ensure this incident is resolved.
Posted Jun 24, 2020 - 15:32 PDT
Investigating
Our Engineering Team is investigating an issue preventing customers from viewing, uploading and downloading files across Procore.
Posted Jun 24, 2020 - 14:29 PDT
This incident affected: Global Services (File Uploads, File Downloads).