Issues with Loading the Owners Invoicing Detail Page
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 06:08 PST
Update
All invoicing detail pages are loading normally once again. This incident has been resolved.
Posted Jan 20, 2021 - 18:22 PST
Investigating
Our Engineering Team is currently investigating issues with loading the Owner Invoicing Detail page. Updates will be posted as they become available.
Posted Jan 20, 2021 - 16:58 PST
This incident affected: Project Level Tools (Prime Contract).