Owners Platform: Notification Issues
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to notifications and this issue is now resolved.
Posted Apr 09, 2021 - 11:04 PDT
Investigating
Our Engineering Team is currently investing issues with notifications being sent from our Owner's Platform. Updates will be posted as they become available.
Posted Apr 09, 2021 - 08:40 PDT
This incident affected: Procore Owners Platform (Dashboard).