Degraded App Performance
Incident Report for Procore Technologies
Resolved
Our engineering team has confirmed that response times have been normal since approximately 1:30pm PDT.
Thanks for your patience.
Posted 3 months ago. May 14, 2018 - 15:10 PDT
Update
Response times have returned to normal, though we are continuing to investigate the root cause of the performance degradation.
Posted 3 months ago. May 14, 2018 - 13:31 PDT
Investigating
We're currently investigating increased load times, occasionally resulting in errors, on the web application. We'll provide an update as soon as one becomes available.
Posted 3 months ago. May 14, 2018 - 13:12 PDT
This incident affected: Web Interface.