Inspection View Page Loading Issue
Incident Report for Procore Technologies
Resolved
Our engineering team has restored normal functionality of viewing an Inspection and is confident there will be no recurrences. This incident has been resolved.
Posted May 31, 2022 - 13:01 PDT
Investigating
Our engineering team is investigating an issue causing a loading screen when viewing Inspections intermittently.
Posted May 31, 2022 - 08:41 PDT
This incident affected: Project Level Tools (Inspections).