Procore.com Fails to Load
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Oct 15, 2018 - 09:48 PDT
Monitoring
Services have been restored to the procore.com marketing site. We will continue to monitor in order to prevent any recurrence.
Posted Oct 15, 2018 - 08:45 PDT
Investigating
We are aware that the procore.com marketing site is currently experiencing problems, and are working towards a solution. If you need to access our services, you may login directly at app.procore.com.
Posted Oct 15, 2018 - 08:03 PDT