Delays in Email and Specification Uploads
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to emails and uploads. This issue is now resolved.
Posted Feb 25, 2021 - 20:57 PST
Identified
Our Engineering Team has identified the cause of the delays and is working toward a resolution. Updates will be posted as they become available.
Posted Feb 25, 2021 - 16:14 PST
Investigating
Our Engineering Team is currently investigating delays in emails being sent and specification uploads. Updates will be posted as they become available.
Posted Feb 25, 2021 - 15:15 PST
This incident affected: Global Services (Emails - Outbound).