Usability Issues in Procore Construction Network
Incident Report for Procore Technologies
Resolved
Our engineering team has restored normal functionality and is confident there will be no recurrences. This incident has been resolved.
Impact Duration: 44 Minutes (9:48 - 12:32 PDT/PST)
Posted Jan 19, 2022 - 10:36 PST
Monitoring
Our engineering team has implemented their solution for usability issues in Procore Construction Network and are monitoring the situation to ensure a complete resolution.
Posted Jan 19, 2022 - 10:19 PST
Investigating
Our engineering team is investigating an issue causing usability issues in Procore Construction Network
Posted Jan 19, 2022 - 10:01 PST
This incident affected: Procore Construction Network (Search, Web Interface).