Partial Outage - Project Timesheets
Incident Report for Procore Technologies
Resolved
During the incident we experienced an issue causing a blank page to appear when bulk editing within Project Timesheets. Our engineering team has restored normal functionality. This incident has been resolved.
Posted Aug 11, 2022 - 09:27 PDT
Investigating
Our engineering team is investigating an issue causing a blank page to appear when bulk editing within Project Timesheets.

Additional Updates will be posted as they become available.
Posted Aug 10, 2022 - 14:16 PDT
This incident affected: Resource Management (Project Level Timesheets).