Support Phone Lines Unavailable
Incident Report for Procore Technologies
Resolved
During the incident we encountered an issue preventing inbound calls to our support phone lines. Our team has restored normal functionality, this incident has been resolved.

Impact Duration: 90 Minutes (5/28 9:30am - 11:00am PDT)
Posted Jun 06, 2022 - 16:18 PDT
Monitoring
A fix has been implemented for the issue affecting inbound calls to our support phone lines. We are monitoring the situation to ensure a complete resolution.
Posted May 29, 2022 - 11:00 PDT
Investigating
We are investigating an issue preventing inbound calls to our support phone lines. We will post additional updates as they become available.

If you are affected by this issue, and still need to contact our support team, our chat and email options are still available.
Posted May 28, 2022 - 10:40 PDT
This incident affected: Supporting Platforms (Support Center).