PDF viewing and generation — service disruption

Incident Report for Procore Technologies

Resolved

The issue with reviewing or creating PDFs has been resolved.
Posted Aug 10, 2026 - 16:29 PDT

Monitoring

Our engineering team has implemented a solution to remediate intermittent errors affecting some customers when viewing or generating PDFs. We are monitoring the situation to ensure a complete resolution.
Additional updates will be provided as new information becomes available.
Posted Aug 10, 2026 - 14:01 PDT

Investigating

Our engineering team is investigating issues with viewing and generating PDFs across multiple areas of the platform. We are actively working towards a solution.
Additional updates will be provided as new information becomes available.
Posted Aug 10, 2026 - 13:40 PDT
This incident affected: Project Level Tools (Commitments, Meetings, Observations, RFIs, Submittals).