Procore Application Degradation

Incident Report for Procore Technologies

Resolved

During the incident, some users may have experienced 503 errors or issues navigating the Procore website. Our engineering team implemented a fix and stabilized the application. Normal functionality has been restored, and this incident has been resolved
Posted Nov 19, 2025 - 12:49 PST

Monitoring

Our engineering team has restored normal functionality and users should no longer be experiencing high error rates or long queue times. We are monitoring to ensure full resolution.
Posted Nov 19, 2025 - 12:38 PST

Investigating

Our engineering team is investigating an issue causing some users to experience 503 errors when navigating the Procore platform. We are working to resolve functionality as soon as possible.
Posted Nov 19, 2025 - 12:34 PST
This incident affected: Global Services (Web Interface).