Application Degradation | 5xx Errors

Incident Report for Procore Technologies

Resolved

Procore Engineers were able to fully restore normal functionality to the Procore application. This incident is resolved.
Posted Feb 11, 2026 - 15:20 PST

Monitoring

Normal application functionality has been restored and Procore engineers are monitoring to ensure a full resolution.
Posted Feb 11, 2026 - 14:51 PST

Investigating

Our engineering team is investigating an issue causing some users to experience errors when navigating the Procore application. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Feb 11, 2026 - 14:46 PST
This incident affected: Global Services (Web Interface).