Intermittent Errors

Incident Report for Procore Technologies

Resolved

This incident has been Resolved.
Posted May 20, 2025 - 08:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 08:20 PDT

Identified

We have identified an issue that is causing intermittent errors across Procore for some customers. Our engineering team is working towards a resolution.
Posted May 20, 2025 - 08:11 PDT
This incident affected: Global Services (Web Interface).