Submittals | List page blank for some users
Incident Report for Procore Technologies
Resolved
During the incident, some users experienced the Submittals List to appear blank. Our engineering team has restored normal functionality, this incident has been resolved.
Posted May 14, 2024 - 10:31 PDT
Monitoring
Our engineering team has implemented a solution to remediate the Submittals List appearing blank for some users. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted May 14, 2024 - 10:10 PDT
Identified
Our engineering team has identified an issue causing the Submittals List to appear blank for some users. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted May 14, 2024 - 09:23 PDT
This incident affected: Project Level Tools (Submittals).