Estimating Tool Loading Issues
Incident Report for Procore Technologies
Resolved
Our engineering team has restored normal functionality to the Estimating Tool. This incident has been resolved.
Posted Jun 24, 2022 - 09:38 PDT
Identified
Our engineering team has identified the cause of an issue causing loading problems in the Estimating tool and is working towards a solution.
Posted Jun 24, 2022 - 09:01 PDT
This incident affected: Project Level Tools (Estimating).