Submittals Tool loading as a Blank Page
Incident Report for Procore Technologies
Resolved
Our Engineering Team has resolved this issue
Posted Jan 16, 2020 - 12:53 PST
Investigating
Our Engineering Team is currently investigating the issue of the Submittals tool loading a blank page. Updates will be posted as they become available.
Posted Jan 16, 2020 - 12:18 PST
This incident affected: Project Submittals.