Issues with Loading Procore
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Jan 14, 2020 - 18:37 PST
Monitoring
Our Engineering Team has implemented a fix and are currently monitoring to ensure this issue is fully resolved.
Posted Jan 14, 2020 - 17:30 PST
Identified
Our Engineering Team have identified the cause of this issue and a resolution is being implemented.
Posted Jan 14, 2020 - 17:12 PST
Investigating
Our Engineering Team is currently investigating issues pertaining to customers receiving errors when accessing Procore. Updates will be posted as they become available.
Posted Jan 14, 2020 - 17:02 PST
This incident affected: Web Interface.