Support Phone Outage
Incident Report for Procore Technologies
Resolved
We have restored normal functionality to all of our support numbers. This incident has been resolved.
Posted May 23, 2022 - 15:32 PDT
Update
We have restored functionality to our standard support phone lines. We are continuing to work towards resolving the issues occurring with our Premier and other specialized numbers.
Posted May 23, 2022 - 09:00 PDT
Investigating
We are investigating an issue preventing calls into our support team to complete as expected. We will post additional updates as information becomes available.

If you need to contact support, you can reach out using email or our live chat feature.
Posted May 21, 2022 - 16:05 PDT
This incident affected: Supporting Platforms (Support Center).