Outage with Premier Phone System
Incident Report for Procore Technologies
Resolved
Normal functionality has been restored to the Premier Phone System and we are confident there will be no recurrences. This incident has been resolved.
Posted May 19, 2022 - 06:46 PDT
Monitoring
The issue with our Premier Support Phone System has been mitigated and our team is monitoring the situation to ensure a complete resolution.
Posted May 18, 2022 - 06:44 PDT
Investigating
We are investigating an issue with our Premier Support Phone System that is currently causing calls to forward to Frontline Support. We will post additional updates as they become available.

If you have been affected by this issue, please contact support via email until this has been resolved. You may request a call back in this method if you would still prefer to talk to one of our representatives. Thank you for your patience.
Posted May 18, 2022 - 06:15 PDT
This incident affected: Supporting Platforms (Support Center).